预警 | Cisco IOS和IOS XE系统远程代码执行漏洞

  • 内容
  • 相关


Image

一、类型

        网络设备

二、概要描述

Cisco IOS是多数思科系统路由器和网络交换机上使用的互联网络操作系统。
Cisco IOS和Cisco IOS XE软件的DHCP中继子系统包含一个漏洞,可能允许未经身份验证的远程攻击者执行任意代码并获得对受影响系统的完全控制。攻击者还可能导致受影响的系统重新加载,导致拒绝服务(DoS)。

三、影响范围

受影响的硬件为安装Cisco IOS 和Cisco IOS XE的思科路由器或交换机,
思科已经确认此漏洞不会影响Cisco IOS XR软件或Cisco NX-OS软件。

四、危害

在网络设备上远程执行任意代码,系统命令等,取得设备的控制权。

五、技术细节

该漏洞是由于受影响软件的DHCP中继子系统中的缓冲区溢出状况引起的。攻击者可以通过向受影响的系统发送一个精心设计的DHCP版本4(DHCPv4)数据包来利用此漏洞。一个成功的漏洞利用可能会使攻击者执行任意代码并获得对受影响系统的完全控制,或者使受影响的系统重新加载,导致DoS。

六、检测方法

检测DHCP中继配置
要确定设备是否配置为DHCP中继,管理员可以登录设备并使用

show running-config | include ip helper-address
以下示例显示运行Cisco IOS软件的设备的命令输出,并配置为将DHCP数据包转发到DHCP服务器地址10.10.10.1的DHCP中继代理:
Router# show running-config | include ip helper-address
ip helper-address  10.10.10.1
Router#
如果设备未配置为DHCP中继,则显示running-config | include ip helper-address命令不会返回任何输出。


检测Cisco IOS软件版本
以下示例显示运行Cisco IOS软件版本15.5(2)T1的设备的命令输出,并且安装的映像名称为C2951-UNIVERSALK9-M:
Router> show version
Cisco IOS Software, C2951 Software (C2951-UNIVERSALK9-M), Version 15.5(2)T1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2015 by Cisco Systems, Inc.
Compiled Mon 22-Jun-15 09:32 by prod_rel_team


确定Cisco IOS XE软件版本
以下示例显示运行Cisco IOS XE软件版本16.2.1的设备的命令输出,并且安装的映像名称为CAT3K_CAA-UNIVERSALK9-M:
ios-xe-device# show version

Cisco IOS Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version Denali 16.2.1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Sun 27-Mar-16 21:47 by mcpre

七、修复建议 

更新软件版本
https://www.cisco.com/c/en/us/products/end-user-license- agreement.html

八、参考

https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170927-dhcp
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-12240

本文标签:

版权声明:若无特殊注明,本文皆为《舜哥哥吖》原创,转载请保留文章出处。

本文链接:预警 | Cisco IOS和IOS XE系统远程代码执行漏洞 - http://www.shungg.cn/post/200

发表评论

电子邮件地址不会被公开。 必填项已用*标注